demo playback start with titlepic

One thing I've noticed particularly with tatsurdcacocaco's Doom UV-MAX youtube videos is the demos start with the titlepic opening and then starts the demo. I like this and I would like my demos to playback the same way, as my current demo library has a mixed bunch of random maps from random megawads, and I don't like to always have to guess what wad it is when someone watches the demos with me.

The only way I could think to do this is playing back an alternate version of the megawad where the DEMO1 lump is added/replaced with the demo I want to watch, and simply open the megawad and let it rip, but that seems terribly inconvenient and I doubt tatsurdcacocaco did that for all of his demos.

I can't seem to find anything like it in the prboom configuration files through. Am I missing something that will simulate the intro sequence before playing back each demo?

video for reference:



Also, in the Doomsday Engine, every time a new map starts the CWILVxx graphic is displayed at the top of the screen for a brief moment, which would also be pretty neat too. Does PrBoom have anything like that?

another video for ref:

Share this post


Link to post

No, prboom-plus doesn't have such functionality. I'm pretty sure that Tatsurd does exactly what you described (replacing the DEMO1 lump).

Share this post


Link to post

i do the same but made it different...
im rendering my videos with sonyvegas, one of the few which can edit easily more videos sources into 1 file.
so I recorded with fraps the intro of each wad I'm interested in (10seconds video) and then the demo.lmp.
then I obviously merge those and render the file afer renaming

Share this post


Link to post

I'm pretty sure it's as simple as renaming the lmp to demo1.lmp and adding it to the -file command.

glboom-plus.exe -file av.wad demo1.lmp
Works for me just like tatsurdcacocaco's videos. I just tested doom2.exe in DOSBOX and it also works.

-EDIT-
Odd, I'm using "Tatsurd-cacocaco DooM2 v1.9 5:56 CN" from http://doomedsda.us/wad84m215.html and it works fine as -file av.wad demo1.lmp in glboom-plus. However, in doom2.exe as -file av.wad demo1.lmp will desync shortly before the outdoor courtyard! Yet running doom2.exe -file av.wad -playdemo demo1 stays in sync!

Share this post


Link to post
HackNeyed said:

Odd, I'm using "Tatsurd-cacocaco DooM2 v1.9 5:56 CN" from http://doomedsda.us/wad84m215.html and it works fine as -file av.wad demo1.lmp in glboom-plus. However, in doom2.exe as -file av.wad demo1.lmp will desync shortly before the outdoor courtyard! Yet running doom2.exe -file av.wad -playdemo demo1 stays in sync!

It could have something to do with the fact that revenant missile behavior depends on the tic number (like if the current tic is even then the missile becomes homing or something). Maybe demos that are played 10 seconds after loading the game may start on a different tic. And maybe glboom-plus fixes it. Just a guess...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now