Sign in to follow this  
Followers 0

Bug: portals / hitscan

Hitscans do not travel through portals anymore, but instead hit the flat/flat portal boundary. Projectile weapons however still travel through portals like they are supposed to. This used to work in the latest official release (3.35.92) but stopped working for the SVN builds. The oldest SVN build tested was r810.

Share this post


Link to post

Yeah, the code for this (which was going to be replaced when the new clipping code is completed anyway) was taken out a while back when some sort of infinite-recursion-causing bug was discovered in it. It'll be working again with everything else in the new clipping code.

Share this post


Link to post

I don't know about the recursion bit (I think SoM handled that) but part of it was removed even earlier due to some type of bug that was causing tracers to hit ledges in front of you. 2S line clipping of tracers was completely broken.

Share this post


Link to post

What to do about wall portals now? In an older SVN I was using (I forgot the number), the wall portal wasn't blocking gunshot or "use" scans, while it was solid against actors. Now it blocks everything (but scan attacks make no hit effect on the portal surface).

How exactly do I use wall-linked portals anyway? I have the main room, and the rooms beyond the portal. For each of them, the portal surface is a one-sided line (wall). Do I have to tag ONLY the sector beyond, give linetype #377 to the portal side here, #376 to the portal side beyond, and link them both to the tag used? Or am I doing it the wrong way?

Share this post


Link to post

For line-to-line linked portals, you don't tag sectors at all. Set it up in much the same way you would a silent teleport: two lines (their front sides facing the direction the portal should render into), one using 376 and the other using 377. Which one is which doesn't matter.

Share this post


Link to post

They have to be on 2-sided lines, with enough room on the other side for the thing moving through it to fit into.

Share this post


Link to post
esselfortium said:

They have to be on 2-sided lines, with enough room on the other side for the thing moving through it to fit into.

Thanks, it works, but now I also get horrendous HOM around the linedef. Here's how it appears: http://i45.tinypic.com/6r7erq.jpg [credits to 40oz for that sky]

Share this post


Link to post

Uhhh...I have no idea what you're doing wrong, but you're clearly doing something wrong, because I've put several line-to-line portals in all of my in-progress EE maps and none of them have ever done that. >_>

Share this post


Link to post

I think I solved it :) I was mismatching the heights of the buffer (behind the teleporter) sectors with the portal (seen through the portal) sectors.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0