Try out v1.9 demo recording!

Eternity can now record demos that aim to play back on the original engine. Give it this command line:

eternity -iwad <whatever> -vanilla -record <lmpname>
You may also give the command line parameter -longtics when using -vanilla, which will result in a v1.91 longtics demo.

Any demo that you record with EE that will not play back in Choco Doom probably reveals a compatibility problem in EE, and may therefore be useful :)

Share this post


Link to post

Awesome. I think I might try this. There is no complevel needed?
For example Final Doom needs a complevel of 4. Would I just have to include -vanilla command line parameter and launch? If so then this is great. I'll be testing around with this and let you know if there are any problems at all with compatibility.

Share this post


Link to post

I might use this as a loophole to perfectly emulate vanilla behavior.

Share this post


Link to post
TendaMonsta said:

Awesome. I think I might try this. There is no complevel needed?
For example Final Doom needs a complevel of 4. Would I just have to include -vanilla command line parameter and launch? If so then this is great. I'll be testing around with this and let you know if there are any problems at all with compatibility.

It currently depends on how you're using the engine. I *think* what should happen is that if you're using tnt or plutonia IWADs, it will behave like Final Doom. If you're using doom2.wad as the IWAD and add one of the others as a PWAD, you'd get one of those "Final Doom in Doom 2" demos; etc.

There are probably bugs with it. I won't know until more people try to use it.

Share this post


Link to post

There is either a problem with -vanilla command or there is a big problem with me.

I recorded a demo via a Doom launcher and I also tried the command prompt.

When I recorded with the Doom Launcher (ZDL) the demo records and shows up in the folder, but it says unknown demo type when I attempt to play it.

I then used the command line prompt and it says demo recorded, but I cannot find the demo anywhere on my Hard Drive. Maybe I am doing this wrong...

Share this post


Link to post
TendaMonsta said:

There is either a problem with -vanilla command or there is a big problem with me.

I recorded a demo via a Doom launcher and I also tried the command prompt.

When I recorded with the Doom Launcher (ZDL) the demo records and shows up in the folder, but it says unknown demo type when I attempt to play it.

I then used the command line prompt and it says demo recorded, but I cannot find the demo anywhere on my Hard Drive. Maybe I am doing this wrong...

I will need the demo file from the first case to debug it. Never experienced this problem during testing.

As for the second, no clue, but ZDL is probably setting Eternity's working directory to something strange. If you are on Windows Vista or 7 you will need to check under your User account's folders for the temporary copy of Program Files that is created there whenever a program tries to write into that folder. If you have installed ZDL in your Program Files folder, it is probably propagating that working directory to the Eternity Engine executable, as such is the default behavior of the CreateProcess API on Windows NT.

Share this post


Link to post

I found out where to demos where being saved and then I tried to record again. This time it saved in the right folder for some reason...

Anyway it still says unknown demo format.

I am using Windows 7 and I downloaded the Win32 "plus" version.

Here is my command line -iwad doom2.wad -file -skill 4 -warp xx -vanilla -record testee

Then I launch....Here is the demo file too since you asked for it.

Share this post


Link to post
TendaMonsta said:

I found out where to demos where being saved and then I tried to record again. This time it saved in the right folder for some reason...

Anyway it still says unknown demo format.

I am using Windows 7 and I downloaded the Win32 "plus" version.

Here is my command line -iwad doom2.wad -file -skill 4 -warp xx -vanilla -record testee

Then I launch....Here is the demo file too since you asked for it.

I don't see a link but I will try using the same command line and see what I get.

Share this post


Link to post

That's not a Doom demo. It starts with the Eternity header information. Make sure the Eternity version you are using is up-to-date. If it's an older version, this feature isn't available.

Share this post


Link to post
myk said:

That's not a Doom demo. It starts with the Eternity header information. Make sure the Eternity version you are using is up-to-date. If it's an older version, this feature isn't available.


The problem is my Eternity Engine is up to date. I am using Windows 7 and I downloaded the Win32 "Plus" version. I have included the -vanilla parameter before I attempt to launch anything. I also tried the Win32 and added the sources, but it always comes up as 255.

I don't know what to do and I feel retarded...

Share this post


Link to post

Don't feel retarded. I imagine you are using the most recent official release, as linked to from here or here?

You need a more recent SVN build from here.

Share this post


Link to post
Grazza said:

Don't feel retarded. I imagine you are using the most recent official release, as linked to from here or here?

You need a more recent SVN build from here.


Thank you everyone for your help. I've finally got it to work. I think I should just search harder and read a lot more information before I start posting questions like this.

Quasar I can now test out this feature and I will let you know if anything desyncs due to compatibility.

(I think its time to have more self confidence)...

Share this post


Link to post
TendaMonsta said:

Thank you everyone for your help. I've finally got it to work. I think I should just search harder and read a lot more information before I start posting questions like this.

Quasar I can now test out this feature and I will let you know if anything desyncs due to compatibility.

(I think its time to have more self confidence)...

Thanks and don't feel bad. It's my fault for not having a better up-to-date webpage for EE that links to the SVN builds :(

Share this post


Link to post

Does this vanilla mode work together with Dehacked-compatible DEHs?

Share this post


Link to post
printz said:

Does this vanilla mode work together with Dehacked-compatible DEHs?

Not if they abuse certain bugs that Eternity doesn't currently support. One such that is currently not functional is the ability to cause the shotgun's max ammo to increase/decrease when firing a weapon that is set to use AM_NOAMMO as its ammo type but uses a codepointer not designed for noammo weapons (A_Punch or A_Saw).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now