Sign in to follow this  
Followers 0

bug

every map name is "new level", why?

ex. : map01:new level

also:it only happends at the automap

Share this post


Link to post

It only happens if you load a new level that doesn't have a name defined in EMAPINFO.

For example, if you play normal Doom II, the level names are there (they aren't new levels). If you play, say, Community Chest 4, the level names are there (there is an EMAPINFO lump). But if you play, say, Plutonia 2, then there are no level names.

Share this post


Link to post

Also if you were to use an IWAD without the proper IWAD tag in the header, prior to v3.40.30, this feature would incorrectly trigger even in the IWAD levels. That's been fixed though.

Share this post


Link to post
Gez said:

It only happens if you load a new level that doesn't have a name defined in EMAPINFO.

For example, if you play normal Doom II, the level names are there (they aren't new levels). If you play, say, Community Chest 4, the level names are there (there is an EMAPINFO lump). But if you play, say, Plutonia 2, then there are no level names.

Even if there's a deh or bex patch defining mapnames? That seems like something of an oversight, if so.

Share this post


Link to post
esselfortium said:

Even if there's a deh or bex patch defining mapnames? That seems like something of an oversight, if so.

No.

I thought you knew :P If a particular level name has been replaced by DeHackEd, the "new level"/"hidden level" logic is never applied.

Share this post


Link to post

Plutonia 2, in ZDoom and Eternity:


And yes, there still is the embedded DEHACKED lump in pl2.wad. (Which itself, if it changes anything, is still in pl2.zip. I like not having to extract mods before being able to load them in EE anymore.)

Share this post


Link to post
Gez said:

Plutonia 2, in ZDoom and Eternity:
And yes, there still is the embedded DEHACKED lump in pl2.wad. (Which itself, if it changes anything, is still in pl2.zip. I like not having to extract mods before being able to load them in EE anymore.)

Looks like something's very wrong then :P

EDIT: I cannot reproduce this, unless I use doom2.wad as the IWAD. PL2 is for Plutonia. Eternity does not use Plutonia mapnames unless the gamemission is pack_plut.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0