Severed bunny head
User Control Panel | Member List | FAQ | Privacy Policy | Blogs | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > PrBoom-Plus, ver. 2.5.1.4
Pages (94): « First ... « 91 92 93 [94]  
Author
All times are GMT. The time now is 12:30. Post New Thread    Post A Reply
Cipher
Green Marine


Posts: 34
Registered: 01-17


Can anyone help me figure out a framerate issue?

In capped framerate mode, it seems to run choppy on every video setting. I'm using Windows 10. I had an identical issue in Crispy Doom until I set it to look to the DirectX video driver, and a similar issue in Eternity until I set it to SDL GL2D.

Also, is there any way to automatically set the automap colors to match the original game? Or a reference for setting its colors manually? Not a huge fan of how many extra hints the default PrBoom+ map builds in.

Otherwise it's a very good port and I'd like to get it working.

Old Post Feb 26 2017 02:06 #
Cipher is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
Revenant100
Ask me about Lost Soul sprites


Posts: 411
Registered: 07-04



kraflab said:
In the most recent 2.5.1.5 test build, my mouse sensitivity is noticeably different than in 2.5.1.4, with the same exact settings in the config file, also verified in the interface in-game.

Is there a way to fully compensate for these mouse movement differences in the newest tested build? In 2.5.1.4, I have my mouse sensitivity to 10, but this setting is far too low in 2.5.1.5. Cranking the sensitivity up to 30 comes close to matching the speed in 2.5.1.4, but the overall mouse movement is still very different.

To specify, in 2.5.1.5, I am not able to turn with the same precision as 2.5.1.4, as if my movements are being dampened. I have to assume mouse acceleration isn't at fault here since that's still set to 0 in my config. However, it really does seem like some sort of noticeable mouse smoothing is being applied, and there's no setting to control that. The difference is very obvious when jumping between versions and just quickly turning back and forth.

Old Post Feb 26 2017 08:08 #
Revenant100 is offline Twitter account Youtube || Blog || PM || Post History || Add Buddy IP || Edit || Quote
38_ViTa_38
Member


Posts: 265
Registered: 11-15



Cipher said:
In capped framerate mode, it seems to run choppy on every video setting. I'm using Windows 10. I had an identical issue in Crispy Doom until I set it to look to the DirectX video driver, and a similar issue in Eternity until I set it to SDL GL2D.

Try to set sdl_videodriver in prboom-plus.cfg to "directx" if you're using SDL1 prb+ (2.5.1.4).

Or a reference for setting its [automap] colors manually?

Options->Setup->Automap->2nd and 3rd pages.

Old Post Feb 26 2017 09:26 #
38_ViTa_38 is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
Cipher
Green Marine


Posts: 34
Registered: 01-17



38_ViTa_38 said:
Try to set sdl_videodriver in prboom-plus.cfg to "directx" if you're using SDL1 prb+ (2.5.1.4).

Huh. It was that easy. Thanks!

Old Post Feb 26 2017 11:26 #
Cipher is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
bonnie
Warming Up


Posts: 13
Registered: 09-16



38_ViTa_38 said:
Options->Setup->Automap->2nd and 3rd pages.

That's not what he meant. When he said reference, he meant a reference, as in a picture or file that already has the correct colors that he can then use to correct the colors in his own config file. I would also greatly like one.

Old Post Feb 26 2017 20:38 #
bonnie is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
Danfun64
Member


Posts: 645
Registered: 07-10


So this problem is connected to SDL2 somehow? Weird...

Old Post Feb 26 2017 20:45 #
Danfun64 is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
Revenant100
Ask me about Lost Soul sprites


Posts: 411
Registered: 07-04



Cipher said:
Also, is there any way to automatically set the automap colors to match the original game? Or a reference for setting its colors manually?

There's no automatic way, but you can open prboom-plus.cfg or glboom-plus.cfg in a text editor and replace the "Automap settings" section with these values:
code:
# Automap settings mapcolor_back 0xf7 mapcolor_grid 0x68 mapcolor_wall 0xb0 mapcolor_fchg 0x40 mapcolor_cchg 0xe7 mapcolor_clsd 0xe7 mapcolor_rkey 0x70 mapcolor_bkey 0x70 mapcolor_ykey 0x70 mapcolor_rdor 0x0 mapcolor_bdor 0x0 mapcolor_ydor 0x0 mapcolor_tele 0x0 mapcolor_secr 0x0 mapcolor_exit 0x0 mapcolor_unsn 0x63 mapcolor_flat 0x61 mapcolor_sprt 0x70 mapcolor_item 0x70 mapcolor_hair 0xd0 mapcolor_sngl 0xd0 mapcolor_me 0x70 mapcolor_enemy 0x70 mapcolor_frnd 0x70 map_secret_after 0 map_point_coord 0 map_level_stat 0 automapmode 0x9 map_always_updates 1 map_grid_size 128 map_scroll_speed 8 map_wheel_zoom 1 map_use_multisamling 0 map_overlay_pos_x 0 map_overlay_pos_y 0 map_overlay_pos_width 320 map_overlay_pos_height 200 map_things_appearance 0
If you're using GLBoom+, you'll also have to disable "Textured Display" to remove the flats rendering.

PrBoom+ does irrevocably change the way a few things are rendered in the automap, but these settings will get you 99% of the way towards matching the original look.

Comparison for reference/funsies:

Last edited by Revenant100 on Feb 26 2017 at 22:13

Old Post Feb 26 2017 22:02 #
Revenant100 is offline Twitter account Youtube || Blog || PM || Post History || Add Buddy IP || Edit || Quote
kb1
Ask me about my source port


Posts: 1218
Registered: 11-06



Revenant100 said:
To specify, in 2.5.1.5, I am not able to turn with the same precision as 2.5.1.4, as if my movements are being dampened. I have to assume mouse acceleration isn't at fault here since that's still set to 0 in my config. However, it really does seem like some sort of noticeable mouse smoothing is being applied, and there's no setting to control that. The difference is very obvious when jumping between versions and just quickly turning back and forth.

If you're running Windows, in the Windows registry, there's a section dedicated to mouse acceleration. The Mouse Control Panel properties apparently don't let you completely turn off this mouse acceleration, and programs cannot do it either (though they may try to cancel it out with tricky algorithms - don't know if PrBoom is doing that or not); but there's a registry hack that does it. I'm sorry that I can't direct you towards it now, but hit up Google - I've heard that that works. Someone else, please confirm.

EDIT: In re-reading, I noticed that you said it changed since last version, so the registry hack might not be the way to go, but then again, it may improve things a different way. I'd love to hear from someone that actually did the registry change: How did it work? Did it improve precision? Did it make the mouse feel more "like vanilla in good ol' DOS"?

Old Post Feb 27 2017 23:28 #
kb1 is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
CapnClever
Mini-Member


Posts: 65
Registered: 09-16


In response to mouse sensitivity: SDL2 grabs "raw" mouse input, unaffected by the Windows operating system, whereas SDL1's mouse input is affected by options such as "Enhance pointer precision". If you're used to the Windows acceleration and can't cope, you'll just have to ask any SDL2-migrating source port to emulate it. Here's an article on the subject.

Old Post Feb 28 2017 00:23 #
CapnClever is offline Youtube Twitch || Blog || PM || Post History || Add Buddy IP || Edit || Quote
Cipher
Green Marine


Posts: 34
Registered: 01-17



Revenant100 said:
There's no automatic way, but you can open prboom-plus.cfg or glboom-plus.cfg in a text editor and replace the "Automap settings" section with these values:

Thanks for this. It's exactly what I was looking for. I'd fiddled around with changing some of the colors on my own, but wasn't sure I was winding up as close to vanilla as I wanted.

Old Post Feb 28 2017 04:46 #
Cipher is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
Danfun64
Member


Posts: 645
Registered: 07-10



Revenant100 said:
Comparison for reference/funsies:
http://i.imgur.com/6eGh7Ae.png http://i.imgur.com/mGjFWsp.png

That automap stretching...

Aside from ports like Chocolate Doom and its derivatives, what ports actually try to keep the correct aspect ratio for the automap?

Old Post Feb 28 2017 06:03 #
Danfun64 is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
All times are GMT. The time now is 12:30. Post New Thread    Post A Reply
Pages (94): « First ... « 91 92 93 [94]  
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > PrBoom-Plus, ver. 2.5.1.4

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by vBulletin
Copyright vBulletin Solutions, Inc.