PrBoom-Plus, ver. 2.5.1.4

entryway said:

lies
This bug has been fixed. And the second will be fixed in release too.

Oh I'm really sorry. I was thinking you didn't fix them because you didn't write it on the changelog. I'm really sorry.
Edit: Don't forget to fix the translucency too please. It won't change (On/Off) until you restart the engine.

Share this post


Link to post
RazTK said:

Don't forget to fix the translucency too please. It won't change (On/Off) until you restart the engine.

I don't understand what you want.

Share this post


Link to post
entryway said:

I don't understand what you want.

The translucency... (Options => General => 'Enable Translucency') when you try to turn it on or off, you will only see it changes if you re-open PrBooM.

Share this post


Link to post

Is it original prboom bug? I don't wish to correct not critical mistakes of the base port. My Prboom-Plus is positioned only as extension for PRBoom.

Share this post


Link to post
entryway said:

Is it original prboom bug? I don't wish to correct not critical mistakes of the base port. My Prboom-Plus is positioned only as extension for PRBoom.

Well... it's kinda suck.
You can change the volume of the translucency without re-open the engine but you must re-open it if you want to change it on/off. But if you don't want to change it, then don't

Share this post


Link to post
myk said:

Let's wait for mouse acceleration first!

test3
Change Log:
[+]Mouse acceleration code.

Share this post


Link to post

entryway said:
test3
Change Log:
[+]Mouse acceleration code.

I've tried it, but the mouse doesn't seem to be responding anymore, and it doesn't seem to be adding an acceleration-related entry to the CFG (even though I did see and modify the acceleration bar in the ingame menu.)

Share this post


Link to post
myk said:

I've tried it, but the mouse doesn't seem to be responding anymore

prboom or glboom? Try to change movement_altmousesupport
EDIT: prboom I think.

and it doesn't seem to be adding an acceleration-related entry to the CFG (even though I did see and modify the acceleration bar in the ingame menu.)

mouse_acceleration

Share this post


Link to post

I see the entries now, and set movement_altmousesupport to 1, but it's still not responding. I had tried with GLBoom as well. Now in GLBoom it does work after setting that to 1, but not in PrBoom (still non-responsive.)

Share this post


Link to post

It still does the same thing; the GLBoom and PrBoom CFGs have more or less the same mouse settings yet PrBoom fails and GLBoom is okay.

Share this post


Link to post

is it possible to merge gl and prboom ? and trigger the GL mode with a simple command line or .cfg line ?

Share this post


Link to post
myk said:

It still does the same thing; the GLBoom and PrBoom CFGs have more or less the same mouse settings yet PrBoom fails and GLBoom is okay.

Oddly. It works fine for me. Send me your prboom.cfg please
e6y at yahoo.com

Share this post


Link to post

2.2.6.24

[+] Option for removing the "wipe" effect.
[+] Option for smoother mouse control. (Probably it does not work on win98. I do not have win98 to test it)
[+] Mouse acceleration code.
[+] Ability to use savegames while using a complevel.
[!] PRBoom compatibility: changes in processing overflow of spechit array.
[!] The "-recordfrom" switch is renamed into the "-recordfromto"
[-] PRBoom.exe: the screen ceases to be updated after start of new game while you are already in game.
[-] Problems with status bar in prboom.exe (2.2.6.21)
[-] -skipsec broken (2.2.6.23)
[-] Few improvements in the sky rendering. No more HOM in the starting area of Memento Mori map29 and an minor issue in map30.
[-] Translucency won't change until you restart the engine.

Share this post


Link to post

Sounds great. Some of this is stuff that I've been hoping would be added/fixed in prboom ever since I first started using it about three years ago. :)

Share this post


Link to post

Thanks, Entryway!
Great Job ;-)
Edit: I'm afraid you forgot to fix the 'Translucency won't change until you restart the engine' thing in GLBoom. ;-)

Share this post


Link to post

I've tried PrBoom+ online using the server in the PrBoom package but it doesn't work. The server closes and one of the clients terminates with "signal 11", or in one case, with a system freeze. PrBoom+ is single player only?

Share this post


Link to post

If it's any help in tracking down the problem here, I can mention that net1 (single-player coop) still works for me, so prboom-plus clearly can work with prboom_server.

Share this post


Link to post

Right, we get the issue when connecting over the net; thae crashing client is the one not connecting to localhost.

Share this post


Link to post
RazTK said:

Edit: I'm afraid you forgot to fix the 'Translucency won't change until you restart the engine' thing in GLBoom. ;-)

I'm afraid you never start glboom\prboom 2.2.6.24

Share this post


Link to post
entryway said:

I'm afraid you never start glboom\prboom 2.2.6.24

What do you mean? ^_^'

Share this post


Link to post
myk said:

I've tried PrBoom+ online using the server in the PrBoom package but it doesn't work.

As would be expected. This task remains to be solved ... or maybe not. Interestingly, how many people in the world use the prboom for a network game :)

Share this post


Link to post

entryway said:
Interestingly, how many people in the world use the prboom for a network game :)

It's hard to know because it doesn't have centralized "master-server" type connectivty. But a considerable amount of people seem to prefer PrBoom or similar ("classic") engines, so there is no reason to believe they aren't using it for MultiPlayer.

Share this post


Link to post

It's one of three ports listed here for online play, so there must have been some interest, possibly dampened by the issues mentioned there.

Share this post


Link to post

RazTK said:
How do I start a net game?

Someone needs to start a server (usually on one of the players' computers but it could be elsewhere) with its command line parameters (check the documentation for which apply.) The clients each connect to it using the -net command, plus the IP or the computer name. On the server it's a good idea to specify the -c command, that lets the server know what CFG to use for the game, from where it takes all the shared CFG info (and leaves aside individual stuff like key bindings and whatnot.) The clients don't usually add anything else to the command line themselves unless selecting the IWAD, recording, or making changes to output.

Check README.command-line.txt for more info. You can also run a server with -N 1 (1 node, or 1 player) and join it yourself with -net and 127.0.0.1 (or localhost), but that's internal and was working for PrBoom+ even before the fix. If you run both the server and the client on your machine each naturally needs its own command prompt (it's good to have a specific shortcut, script, or batch for the server.)

One thing I noticed is that the server dictates the path to the PWADs used, so it's best for the clients to have them in the same directory as the engine (unless the clients and the server all have the same subdirectory structure for PWADs.)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now