Sign in to follow this  
Followers 0

why is vavoom so god damned slow?

why is vavoom so god damned slow? every other port runs like lightning! except vavoom, it runs like shit and its pretty crashy.

Share this post


Link to post

Actually the reason is because most of the physics / AI code is implemented in VavoomC scripting language which is interpreted and that's why slow. Even more - currently compiler doesn't perform any code optimization. To improve performance some code will be moved back into engine, but this will mean that mod authors won't be able to customize it, but this will run faster.

JL

Share this post


Link to post

why is vavoom so god damned slow? every other port runs like lightning! except vavoom, it runs like shit and its pretty crashy.


Don't get Vavoom, get some other port(s).
Vavoom sucks eggs.

Share this post


Link to post

Oh yeah, footman, change your sig. It's too disturbing. You should never wish you want to be dead.

Share this post


Link to post

k thx DooMBoy ill chanhge it asap and i might as well get rid of vavoom, youre right, it does suck eggs

Share this post


Link to post

Thank you. Now I don't need to call the SWAT Team to come get you.

Share this post


Link to post

So, retox, you're the author of Vavoom? Really?
Can you explain why the game crashes in Direct3D mode, hangs in OpenGL mode, and performs only half-decent in software mode (for me at least)?
Understand, I am not trying to hurt your feelings or anything: I'm merely curious.
??

Share this post


Link to post

So, retox, you're the author of Vavoom? Really?
Can you explain why the game crashes in Direct3D mode, hangs in OpenGL mode, and performs only half-decent in software mode (for me at least)?
Understand, I am not trying to hurt your feelings or anything: I'm merely curious.
??

i agree, vavoom is one of the worst source prts ive seen!(so far)

Share this post


Link to post

Since Direct3D is slower than OpenGL (at least on GeForce2), I only sometimes running Direct3D. OpenGL runs fine, I don't have crashes because of OpenGL already a long time. Software - it's a new, Quake based driver, there's only about 5% from old Doom renderer. And some things, such as colored lighting, are slow. And, of course, compared to old Doom renderer it's realy slow.

Share this post


Link to post

Retox, fuck these idiots. These are the same bunch of guys (not these guys in particular but DW forum lamers) who can't get a TNT2 to run Hexen II.

I think Vavoom rocks. Keep up the good work!

Share this post


Link to post

Hmm I don't have a problem with the framerate, but it's the game pace that seems slower than Doom. It feels like I'm playing it in slow motion somehow.

I was trying to figure out the progs thingy, and managed to make the fist silent.

Maybe someday I'll make a version of GunsPC for Vavoom.

Share this post


Link to post

ESPI IF YOU DO I WILL CATCH A PLANE TO <where you live> AND SUCK YOU OFF

Share this post


Link to post

I like VaVoom... it has alot of potential... but I found it a bit buggy when I played with it, so I haven't touched it since... I might try the latest version out and see if that's improved any

Share this post


Link to post

ESPI IF YOU DO I WILL CATCH A PLANE TO <where you live> AND SUCK YOU OFF

Getting desparate are we, Kat? ;)

Share this post


Link to post

I think it's more like a reward because someone actually did something for VaVoom... say, are there actually any mods for VaVoom?

Share this post


Link to post

Since Direct3D is slower than OpenGL (at least on GeForce2), I only sometimes running Direct3D. OpenGL runs fine, I don't have crashes because of OpenGL already a long time. Software - it's a new, Quake based driver, there's only about 5% from old Doom renderer. And some things, such as colored lighting, are slow. And, of course, compared to old Doom renderer it's realy slow.


Hmmm... Man I never knew that, I just thought it was slow and crappy. I really do need to upgrade my motherboard and CPU (Its only 350mhz). One thing that refrains me from playing it though, is that sprites keep disappearing all the time, so Imps will be throwing nothing at me, except this 'nothing' will still light up the walls and stuff around it...

Well keep up the good work then, hope to see an optimised version soon! (Then I might be able to play it at a framerate over 10fps, heh)

Share this post


Link to post

Hmmm... Man I never knew that, I just thought it was slow and crappy. I really do need to upgrade my motherboard and CPU (Its only 350mhz). One thing that refrains me from playing it though, is that sprites keep disappearing all the time, so Imps will be throwing nothing at me, except this 'nothing' will still light up the walls and stuff around it...


... but I have a 300MHz CPU ...

Problem with flickering sprites is because of network packet overflows and it can be fixed, or at least improved, by creating full vis data usung external glVIS utility (You can grab it from Vavoom homepage).

Well keep up the good work then, hope to see an optimised version soon! (Then I might be able to play it at a framerate over 10fps, heh)


I'll do the best I can.

Share this post


Link to post

I have to use that vis thing?
I was going to, but it would've taken ages, so I cancelled it. Oh well, maybe when I have the time...

Share this post


Link to post

I have 2 gripes with vavoom.
Monsters and items etc. are sunken into the ground why can't i see the base legs of the imps etc. i only see half of a healing potion.
I can't play alien vendetta with it. When Vising it stops on map 23 - 7370 sectors or something like that. I think the alien vendetta wad is a bit sloppy maybe. Only source port I've ran it with is regular zdoom. (the only windows source port that doesn't suffer slowdown with masses of monsters)

Share this post


Link to post

Vavoom's dyn. light's looked amasing on Winnowing Hall.
Few problems:
bot's don't appear when I try to play Hexen in deathmatch with them.
Everytime I choose Evilution's IWAD, Vavoom keeps building the vis-data and GWA-file, with other IWAD's it does it only once like it should.

Share this post


Link to post

Foots in flors - it's because Vavoom uses z-buffering. There's no fixes for this problem and all OpenGL and Direct3D port authors will say the same.

Allways rebuilds GWA - that means that wad file has a modification date in the future. Try to modify it somehow or change date for example with DOS Navigator (sory, can't tell you how to do this with Windows tools).

No bots in Hexen - yes, in Hexen bot's are not yet implemented.

Oh, and that "slow motion" bug has been fixed, expect a new version soon.

Share this post


Link to post

vavoom runs perfect on my shitty 500mhz celeron at 1024x768, so all you vavoom haters stfu.

however, i have one question though. how do i get the bots working (doom1/2) without it crashing?

Share this post


Link to post

Vavoom does seem to run Icarus & Eternal, however, when there are lot's of MD2 models on the screen same time, they start to flicker, and when there's even more of them, they disappear completely! Is there any way to stop this, or disable MD2's?

BTW, bots seem to vanish when a new level starts, and when i try to add them, it says "server is full".

Share this post


Link to post

vavoom runs perfect on my shitty 500mhz celeron

That's actually an above average computer for someone in the Doom community :)

Share this post


Link to post

considering that before my parents divorced, i had a 1.4ghz AMD athlon... meh.

Share this post


Link to post
This topic is now closed to further replies.
Sign in to follow this  
Followers 0