Doom Legacy 1.44 has no Launcher

I am attempting to play Phobia - The Age, which apparently requires use of the Legacy source port. The problem is that the latest builds of Legacy (1.44) do not include a launcher, even though the 1.44 User Reference Manual says it should be included under the install section: http://doomlegacy.sourceforge.net/docs/legacy.html#install . What am I missing? The 1.42 build does include a Launcher, but it crashes whenever I attempt to use OpenGL. I am downloading the 1.44 builds from the official site: http://doomlegacy.sourceforge.net/. Can anyone explain what I need to do? I would very much appreciate any help.

P.S. In the 1.42 build, the launcher only seems to allow for the loading of IWADs. How are PWADs loaded in Legacy? Thanks.

Share this post


Link to post

DoomLegacy 1.44 does not include or formally support a launcher any more.
Most settings are available in menus or from the console.
As far as we know, it is compatible with the older launchers.
We have tried to ensure that older command line switches they used are not changed.

It is developed on Linux and we are very used to just typing out the
commands to run it.
The only Windows I have to test with is Win98 and I use the Dosbox
there to start it.

The latest DoomLegacy has a help screen.
>> doomlegacy --help

Some example command lines
>> doomlegacy -game doom2
>> doomlegacy -iwad doom2.wad
>> doomlegacy -file phobia.wad
>> doomlegacy -game freedoom -file phobia.wad snd2.wad music18.wad

As far as I know, there are ways to create shortcuts in the latest Windows that have an editable command line. This way a phobia shortcut can be created containing the required command line switches.

Wesley Johnson, DoomLegacy Development team

Share this post


Link to post

I used C#4rp Doom Launcher on 1.44 and it launched Legacy ok. I didn't test it after that tho as I couldn't get it to run in my resolution probably because it's stuck in software mode and I don't know the trick to changing it.. :p Anyhow, I only installed Legacy to see if it would run with that launcher.

Share this post


Link to post

DoomLegacy will detect most resolution capabilities and this is changed in the video menus. There are command line switches for the emergency case where the config file is not set to a valid resolution.

The alpha releases only have software and OpenGL rendering.
Software rendering is default. Highcolor has been broken for the past decade.
>> doomlegacy -opengl

In the SVN repositories, the latest commits support additional direct rendering. Highcolor has been fixed.
>> doomlegacy -native
>> doomlegacy -truecolor
>> doomlegacy -highcolor
>> doomlegacy -bpp 32
>> doomlegacy -bpp 24
>> doomlegacy -bpp 16
>> doomlegacy -bpp 15

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now