Missing flags in Odamex and Zandronum

So, when I tried to run Epic CTF in Zandronum and Odamex, the flags refused to appear in both source ports. In Odamex, only the pedestals appeared, but not the flags. In Zandronum, no flag sprites were loaded, only the "missing content" sprite. The game complained about BlueFlag and RedFlag having no frames. The flags don't work at all in either source port! What the hell is going on here?

Share this post


Link to post

With Zandronum, you have to load skulltag_actors.pk3 and skulltag_data.pk3 in order to get flags to appear. The flag sprites are (oddly) not included in zandronum.pk3

With Odamex, the pedestals are design choice. You are not assigned to a team in single player so it does not spawn any flags. The pedestals are drawn for a CTF mapper's convenience, though so that they know where their flags are.

If you want to see the flags, just launch a CTF server with odasrv and "connect localhost"

Share this post


Link to post

Odd... There is no file called skulltag_data.pk3 at all! I'm 100% sure I didn't remove anything! However, Odamex works fine.

Share this post


Link to post
NerdKoopa said:

Odd... There is no file called skulltag_data.pk3 at all! I'm 100% sure I didn't remove anything!

I believe you have to download it separately.

Share this post


Link to post
NerdKoopa said:

So, when I tried to run Epic CTF in Zandronum and Odamex, the flags refused to appear in both source ports. In Odamex, only the pedestals appeared, but not the flags.


In Odamex, the flags are only spawned on the map when you're connected to a server running the CTF game mode (sv_gametype 3). In single player mode, you'll only see the flag pedestals.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now