PRBoom+ all of a sudden slow...

I am running Win7 64 bit, and PRBoom+ used to run fine. Now, all of a sudden, it runs at about half speed. No crashes or glitches, just everything is slow. Playing back demos is slow as well though they never go out of sync.

I haven't changed video drivers, haven't really installed anything. I have Samsung Magician running which sometimes prevents PRBoom+ from running in full screen, but that isn't an issue now. Even when I kill Magician PRBoom+ still runs slow.

Running a GeForce GTX-670 and i7 3770K so it's not the horsepower - anyway, it has been running fine for the last few months (I built this computer over the summer), and now it is pretty much unusable. I like to watch demos with it, but each demo now takes 2 times as long to play back and while I appreciate watching the tricks in slow motion it is not feasible for long demos.

Any thoughts?

Thanks,

mp.

Share this post


Link to post

It sounds like you might have accidentally reduced the gamespeed to 50% (e.g. by pressing "PAD-"), and setting it back to 100% ("PAD*" by default) would solve the problem.

Share this post


Link to post

That is exactly it. Thank you and boy do I feel foolish. I had some papers on my desk which were moved and laying on the "-" key on my keypad which of course slowed the game down. I started it up, pressed "*" on my keypad and off we went.

Thanks again, you saved me from frustration!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now