Sign in to follow this  
Followers 0

Stream Read Error

I have an error, it occours when I try to load a 16bit.bmp:

"Stream Read Error" Then it puts an unnamed Marker in its place.

Deepsea(might have misspelled it) can do it fine, (I got a freind to do it) Do I have to convert it to the DooM Pallet First(Thats probably it, but I Dont have a program that can do that. PSP Expired)? I would really like to know whats going on...

Sorry if I seem pushy, but this error is just starting to get under my skin lol.

Share this post


Link to post

Please email the picture to me: xwe(at)rogers.com. Thanks.

Share this post


Link to post

Thanks for sending me the files. They are actually plain 24 bit images. I opened and resaved them with PhotoShop, XWE read those files without any problem. So I compared the two files to find out what's different: only two bytes! In your original files, on position $22 there are these two bytes: $02, $30. The files that PhotoShop saved were identical except there were $00's there. So Delphi's BMP reader messes up because those two bytes. Weird.

I wrote my own custom BMP loader instead, now they load fine. Probably needs extensive testing. Grab the beta: http://ca.geocities.com/xwe@rogers.com/xwe_beta.zip. Let me know if you find any more problems.

Share this post


Link to post

Awesom, thnx, ill be shure to check it out. Good luck with XWE.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0