Sign in to follow this  
Followers 0

XWE FileType Number list

Is ther a list of the File Type Numbers
Ex
WAVESOUND = 55

and so on

Share this post


Link to post

That list is dynamic, the numbers are arbitrary, depending on how much stuff is declared in XWE.INI. If you right click any entry and point to SHOW ONLY, you can see the list. Why do you need it?

Share this post


Link to post

Alot of times, when I insert new entries, it will leave is as either Type 0, or as a Marker, depending on nothing that I've noticed. When I tried to change the File types to WAVESOUND instead of 55, for example, it would make its type the blank 0, albeit, it was still in tact (I think thats how you would spell it)

Share this post


Link to post

When you insert a new entry the type will be 0/marker, unless you name it something that XWE recognises. (E.g. D_RUNNIN will be MUS type.)

Why would you want to change it to WAVESOUND though? It's an empty lump.

Obviously I could add a little dialog box for entry type chaning, with all the types listed and selectable from a dropdown, etc. I just want to understand what is it that you're trying to do.

Share this post


Link to post

Usually, I rename Wav files inside the Wad, rather than rename them prior to inserting them. Im using Wavesound as an example. Other than that, and the random Sprites to Hex lumps thing (Happened to me 3 times on my project, thank god for the backup feature), I could ask for little more, Maybe a way to let WhackEd edit a Dehcked Lump inside the Wad?

Share this post


Link to post

I still don't understand your problem. If you rename a WAVESOUND entry in XWE, the type should not change - unless you rename it to something that XWE recognizes.

What is the "random Sprites to Hex lumps thing"?

What about WhackEd? That's a separate util, you should run it independently of XWE.

Share this post


Link to post

There was no problem, I was just asking if there was a list of File Type Numbers, as when I load a wavesound into XWE, that XWE doesnt recognize, it saves it as a Marker, and the only way to change the type is by using the Type Numbers.

Every now and then, my sprites turn into Hex Lumps or what-have-you in XWE, its rare, but it happens. And by turning into Hex Lumps, I mean you open the Wad, and then you click on the sprite, and it shows some hex rather than the sprite.

About WhackEd, geh, nevermind

Share this post


Link to post

Okay. Two requests:

- If you ever find a WAVE file that XWE doesn't recognize, email it to me.

- If any of your sprites (or any other lump for that matter) show up as just a hexlump, what's just a minor dislpay bug. XWE can't determine the lump type (changing it manually would help) - but my point is there's no need to restore a backup or anything like that. Your sprite is fine. My request: once you have one of those, email me the WAD file. Determining what is a valid doom image (that include sprites) is tricky, I've tried to fine tune it as much as possible, but there still may be some images that don't get recognized. Once I have them, it's easy to adjust XWE.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0