Custom Texture Brightness

Hey everyone, I just recently got XWE and learned how to import custom textures but with some that I made in photoshop the brightness (or contrast?) is raised by a lot when I import them. Anyone know why this is or what I can do to solve this besides making the brightness really low before importing them? Maybe it has to do with the quality I saved them as?

Share this post


Link to post

It sounds like XWE is automatically converting your images to the Doom palette. This tends to result in a palette-raping if you don't prepare the images properly before importing. Stuff with fine shading, especially in the blue and orange ranges tends to look like shit otherwise.

If this is your problem, since you are using Photoshop, you could try saving the images in "Indexed color" mode, instead of "RGB", and selecting one of these palette files when it asks you for one.

That way, you will be able to see what the image looks like in the Doom palette before you import it, and you'll be able to clean it up at the same time, if you need to. Another helpful thing toward this end might be this set of Doom palette swatches for Photoshop, which will let you have all the colors in the palette available in the swatches toolbar for quick touchups.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now