Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
OpenRift

Eternity Engine MIDI Volume Issue

Recommended Posts

So, I've been messing around with source ports today wanting to play some Ancient Aliens, so my best (and favorite) option was the Eternity Engine so I'm able to use the WAD's additional ZDoom features. So, as much as I love the port, the one problem I have is that, much like Chocolate Doom, I can't adjust the MIDI volume at all. Don't get me wrong, Ancient Aliens still has one of if not THE best soundtrack in a singleplayer megawad, but I want to at least turn the damn thing down to something more comfortable. Anyone know any solutions to this? For context, I do use virtualmidisynth with a SC-55 soundfont.

Share this post


Link to post
1 hour ago, Edward850 said:

You are missing the midiproc executable. Download the latest non-beta version and that will have it. 

Thing is, midiproc.exe is right there and has been since I downloaded Eternity today.

image.png.f4d492e94b0d03ade166a9704745a470.png

Share this post


Link to post
2 minutes ago, Edward850 said:

That's quite strange. Is midiproc running in the OS task list after you launch Eternity?

Looks like it to me...

image.png.03dbea2ab8537e24786877bd6fc94aa8.png

Share this post


Link to post

I've run into something similar when using VirtualMidiSynth before.

 

I was able to fix it by going into the volume mixer (right click on the speaker in the taskbar) and turning down the VirtualMidiSynth slider there.

 

(I think this happens because VirtualMidiSynth intercepts all MIDI playback, so volume options in any program do nothing)

Share this post


Link to post
1 minute ago, finnks13 said:

(I think this happens because VirtualMidiSynth intercepts all MIDI playback, so volume options in any program do nothing)

Yup, this is sounding like the case. With midiproc running and looking like it's taking events, I can only assume this is just VirtualMidiSynth behaviour.

Share this post


Link to post

midiproc tends to bug a little if there is another program that also uses midi in the back.

Doom Retro has this also, and the only solution is to close Slade (or whatever program in the back than can reproduce midi) open the volume mixer WHILE in game and check if the sound come from the midiproc or the EE. If it come from the EE close it and reopen it, and check again the volume mixer, if the sound is coming from the midiproc, adjust it to your current max volume output and thats it.

Its tricky, but well...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×