Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Impie

Doom Builder 2 Visual Mode Choppy Movement

Recommended Posts

I used DB2 on my desktop comp all the time and had smooth movement in visual mode, but on my laptop it's choppy as hell for some reason. Is there a shortcut that makes the camera snap to a grid and I accidentally bumped it? What else could be causing this?

Share this post


Link to post
14 hours ago, scifista42 said:

Reboot the laptop.

I shut it down every night and it's still choppy. In fact it seems worse now than it did when i first installed it.

Share this post


Link to post

You have to actually do a restart rather than shutting it all the way off and then turning it back on again. At least, that's what works for me. It's something to do with the program going out of sync with your computer's internal timer.

Share this post


Link to post
15 hours ago, scifista42 said:

Reboot the laptop.

This is not the issue!

 

To OP: I have had this same exact problem with DB2 and GZDB for as long as I have used them. Doing something like playing music with WMP or having any other application running makes it worse and as if I am getting 30 FPS. Closing said application instantly makes it smoother again but it remains choppy. I have no idea what causes this and no idea how to fix it.

 

At this point, I blame my video drivers / video card.

Share this post


Link to post
2 hours ago, Nevander said:

At this point, I blame my video drivers / video card.

 

That, most likely.

 

Something else you might try is to reduce the view distance

Spoiler

H30rdbY.png

 

Share this post


Link to post
10 hours ago, Impie said:

I shut it down every night and it's still choppy.

Well, putting my laptop to sleep mode or hibernation mode doesn't improve the issue in the slightest, but doing a proper full shutdown or reboot always makes movement in DB2 smooth again.

Share this post


Link to post

I've even done hard reboots and nothing doing. And my view distance is at 1000, but there's no difference when I adjust it.

 

It seems strange that this brand new comp would have a worse graphics card than my seven-year-old desktop that just died from a stroke.

Share this post


Link to post
8 hours ago, Impie said:

It seems strange that this brand new comp would have a worse graphics card than my seven-year-old desktop that just died from a stroke.

It does indeed. My old ass Windows XP computer seemed to have better performance in games and programs and I never used to need to tweak settings to get them to run smooth. Now all I do is tweak on hardware that is supposed to be twice as powerful. Even then I get nothing but stuttering, lag, and all multitudes of other bullshit. AMD's drivers must have really gone down the shitter or something over the years. Or there's something else in my PC at work and I can't seem to figure out what it is.

Share this post


Link to post

I've noticed that sometimes it's choppy and sometimes it's not, regardless of how much available RAM you have. It's weird really weird. When it's running smoothly, tapping the forward button will move you just a hair, similar to actual gameplay. However, when it gets all choppy, a single tap will move you the equivalent of like 8 or 12 units, maybe more, making it difficult to position the camera precisely when trying to make minute adjustments in 3D mode. Sometimes it'll be this way for weeks then suddenly start running smoothly again.

Share this post


Link to post

Here's what's REALLY strange: if i'm flying in 3d mode and i hit "G" to drop to the floor, the vertical movement is smooth. But when I move using the movement keys in 3d mode it's choppy as fuck.

Share this post


Link to post
On 29.6.2017 at 2:16 PM, Impie said:

It seems strange that this brand new comp would have a worse graphics card than my seven-year-old desktop that just died from a stroke.

So, what graphics card DOES it have?

If you now say "Intel", well, there's your problem. Even the best current Intel chipsets cannot really compete with a 7 year old graphics card made for gaming.

 

Share this post


Link to post

I have this stupid problem too. In Windows XP the 3D mode was always smooth, now in Windows 7 it can be choppy if it wants. I think turning on vsync helped a bit but not sure. Also Zoom Player sometimes crashes now while going between windowed and fullscreen, Firefox is unbearable whenever something Flash-related is active, Doom with capped movement feels weird too but not sure if I just forgot how it was. Installing an older Nvidia driver at least made it so programs just crash without crashing the driver itself, which I guess is an improvement. Oh, and then there are all the midi problems. Why did I install Windows 7?

Share this post


Link to post
6 hours ago, Memfis said:

I have this stupid problem too. In Windows XP the 3D mode was always smooth, now in Windows 7 it can be choppy if it wants. I think turning on vsync helped a bit but not sure. Also Zoom Player sometimes crashes now while going between windowed and fullscreen, Firefox is unbearable whenever something Flash-related is active, Doom with capped movement feels weird too but not sure if I just forgot how it was. Installing an older Nvidia driver at least made it so programs just crash without crashing the driver itself, which I guess is an improvement. Oh, and then there are all the midi problems. Why did I install Windows 7?

Didn't have any issue with 7 running all this stuff. It's 10 that's giving me trouble right now.

 

8 hours ago, Graf Zahl said:

So, what graphics card DOES it have?

radeon r8 m35odx, if it matters. Apparently this is a worse card than the shitty integrated intel card i had on the 7 year old comp.

Share this post


Link to post
17 hours ago, Impie said:

radeon r8 m35odx, if it matters.

I'm on a Radeon R9 270X, so we are both on AMD. Not a good sign... AMD strikes again. I notice for me GZDB lags even more if I quickly move my cursor over different lines with lots of stuff on them. Lines all with the same properties (no offsets, same texture, no line properties) it doesn't lag hardly at all. Moving over lines with actions and with flags set is a stutter fest. That's with only GZDB running too.

Share this post


Link to post

R9 290 here and no issues, wouldn't blame AMD at this point. Check the power options on your laptop and see that when it's plugged in all options are set to maximum performance - make sure its not throttling your PCIe bus or something.

Share this post


Link to post

Are your drivers up to date? Because mine aren't. I highly doubt that updating them would make any difference since it's AMD and everything.

Share this post


Link to post

I had this problem when I switched from a old laptop to new, more powerful one. I don't think the graphics card or RAM has anything to do with it (the old one only had the integrated one while this one has that and a dedicated one). Have you tried switching to GZDoom Builder? Visual Mode there runs perfectly for me while DB2 still lags like a poorly made dungeon crawler.

Share this post


Link to post

There is definitely something with the 3D mode crosshair and what you point it at that affects the lag for me. Moving around in void space is smooth enough, but as soon as I start moving over linedefs it starts chugging. I wonder if this is just poor optimization in the program itself?

Share this post


Link to post
On 7/3/2017 at 4:11 AM, Zulk-RS said:

I had this problem when I switched from a old laptop to new, more powerful one. I don't think the graphics card or RAM has anything to do with it (the old one only had the integrated one while this one has that and a dedicated one). Have you tried switching to GZDoom Builder? Visual Mode there runs perfectly for me while DB2 still lags like a poorly made dungeon crawler.

I guess I could give it a shot if it doesn't bork my maps when I load them in a different thing.

Share this post


Link to post

@Impie As long as you don't load them in a different map format, it shouldn't mess things up. At least it didn't happen to me.

Share this post


Link to post

Each of the 3 Doom map formats (Doom, Hexen, UDMF) is standardized, not editor specific, so of course that you can load any map in any editor you want, as long as the editor supports that map format, which is satisfied in this case, as both DB2 and GZDB support all 3 formats.

Share this post


Link to post

As Scifista said, a cold reboot always fixed this issue for me (Windows7 Doombuilder2). I always assumed it was some form of memory leak.

Share this post


Link to post

If it was a memory leak, it would go away if you just closed DB2 and opened it again, and not become worse and worse with time even as you keep closing and opening the program. According to this post, it's probably an issue with the way DB2 handles clock.

Share this post


Link to post

I vaugly remembering it being about cache. Just restart your computer and the problem will fix it self. A better solution would be to draw your doom map on graph paper at first and only - only use doom builder to build the final product.

Share this post


Link to post
16 hours ago, NeedHealth said:

I vaugly remembering it being about cache. Just restart your computer and the problem will fix it self.

I've tried this though and the problem persists, unless I don't actually have the option to actually shut down/reboot the computer. I made sure my settings were set to shut down and not sleep on shutdown (seems like a stupid option -- if i wanted it to sleep, i'd pick sleep). As far as I can tell, when it shuts down, it shuts down, but maybe it's not actually doing so, so nothing refreshes. I wouldn't know how to be sure.

Share this post


Link to post

Now it's slower than ever! At this rate it'll probably crash or something.

 

So I decided "fuck it" and switched to Gzdoom Builder...and I can't figure the palette problems out. It shows the correct colors in visual mode, but when I browse the texter choices the Heretic color palette is borked.

 

EDIT: Apparently the palette problem sorted itself out with a reboot. Weird.

Edited by Impie

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×